Form Disappeared in Word Press, which was part of a campaign

Images below text FYI
My form created in Infusionsoft was getting hit with spam the last few weeks. I finally mustered up the courage to log in to wordpress to try and stop it from happening since calling support got me no where. Today I updated plugins, the WP version and my PHP to 7.4
In doing so, I lost how things were linked to each other, for example all my pages were published to the ‘home’ navigation. While I have that shorted out, I’ve LOST my CONTACT US FORM entirely. So while that’s 1 way to stop the spam, it’s going to stop all incoming leads from actual clients.
So here’s the 411.

  1. Form was created with in campaign builder and appears to still be there. It can be opened using the hosted URL.
  2. In wordpress (WP) along the navigation, you can see forms, and the form “Contact Us”, however it has lost the ID form number. I believe it’s considered a gravity form?
  3. So my contact us page is there, but it says the form can’t be found.
  4. I’ve tried to embed javascript, the hosted URL, and HTML unsuccessfully.
    This is a contact form, NOT an opt-in form.

I’m not a web building savvy kinda guy. I’m currently DIYing. Life has thrown me curve balls the last 3 years (long story) so I can’t afford to pay anyone to fix this, and infusionsoft will be the next thing I cut if I can’t get this fixed fast. Having the fancy campaign is useless if I can’t get anyone into the funnel.

Please help. I’m desperate.


If the form was built in Campaign Builder, it isn’t a Gravity Form (two completely separate things).

If you want to use the Web Form that was created in the campaign builder (which, based on what I see, is not the right one) - you would copy the ‘unstyled HTML code’ from the form itself and insert that into your site.

Since you are looking at Gravity Forms (GF) and you have a GF shortcake there, then I would say that you are using a GF.
I think your issue may be with the plugin that you are using. If it is the one I’m thinking of, it hasn’t been updated in years.
Click on the ‘forms’ link under your main ‘forms’ list (in the screenshot it is the word ‘forms’ under the blue highlighted ‘forms’). In there, you should see your Gravity Form.

If you see your form there, I’d consider getting another plugin to connect your GF to Keap. If you want something really stable, you can go with GravityPerks (their free is good but if you want to apply tags, etc. you need to upgrade). The other option would be to get Make (very much like Zapier - only better - and cheaper) and build your connection (they offer 1000 actions for free, so unless you had a lot of volume, you could probably use their free plan).

If you click on the ‘forms’ link and there is no form there, then you somehow deleted your form. Just click on the ‘trash’ link at the top of the form list and undelete/recover that form and it should return. Then go through the processes above.


Hello Jeff - thanks for the reply.
I have two gravity form plugins. TBH I don’t know if I was actually using either.
Gravity Forms and Gravity Forms Infusionsoft Add-ons. (See screenshot).

Under Forms: Gravity Forms - there are zero available. (see screenshot) so there’s nothing in the trash.
This is why I thought I was using the form that is in the campaign that is designed to trigger a new contact campaign.

My IS account is connected propertly. I tried to use wayback machine to find an example of it visually but the format is wrecked.

Is there a way to use the form in the campaign?
I’m 8 hours into this today and losing my mind, or maybe I lost it yesterday - who knows. :wink:


Ok …

The reason I said you were using GF is that you had a GF shortcode in your first post.
You can use the Keap form.
Go to the form.
Click on the ‘code’ tab at the top
Copy the ‘unstyled HTML code’
Paste that into the page of your website where the form should go (how to paste is determined by the type of builder you have — but if you can insert a widget with an HTML code field, that’s probably what you want)


Ok - that’s what I tried to do unsuccessfully while on the phone with IS Support earlier.
We tried to embed, use the html format or use the link to insert all failed.

Hmm … getting deeper than just a ‘form’ issue at this point. Not something we could troubleshoot via the community.
Would require a tech person to assist.
We’re avail for hire, but based on initial post, that’s not possible.