User clicks Form button and it loads forever. What do I do?

This has been a known issue for me and my team since the beginning of this year. The way we found to hotfix it would be to re-insert the forms into the OptimizePress pages, but it just stops working after a random period of time. It’s hurting our userbase directly, and we’re losing leads because of it. Before the problem gets bigger than it already is, I’d really like to know if there’s a known fix to this.

Disclaimer: If I’m logged in as administrator, for some reason, the form and the campaign work just fine.


It’s been like this for at least 2 minutes and I made sure that it isn’t my internet connection, so please don’t go there.

Thanks in advance.

Its going to be hard to say without a link to the live page. It seems like a script or coding conflict potentially.

You can try inspecting the page in Google Chrome to see if there are any errors in the ‘console’. It may take a refresh to see an errors in the console.

Have you tried using the IS landing page plugin? This is often permission based when a form loads for a long time but as state, providing a link would be most helpful to be more certain of anything.

Alright here’s the link: INSCRIÇÃO EBOOK 7 DICAS - Jung na Prática

And I’ll make sure to test these 2 options out. Thanks in advance, but the issue is not resolved.

EDIT: The console displayed a 403 error with the Jquery ajax. I’ve indexed the javascript within this post. Please give it a look! :slight_smile: Here’s the full code: jquery with 403.pdf (145.5 KB)

Console message: "
jquery.js?ver=1.12.4:4 POST 403 (Forbidden)"

UPDATE: Apparently changing the membership options of the page to “Product” made the form to be working again, but I’m not sure it worked because of the hotfix possibility I showcased on my first post. I suggest we wait until tomorrow to see if the issue is fixed.

SECOND UPDATE: It didn’t fix. I’m gonna try to change the script’s permissions on the FTP server.

THIRD UPDATE: Changing the file: “jquery.query.js” permissions from 644 to 755 apparently fixed the issue. Let’s wait until tomorrow to see if any automatic changes are being made. I’ll inform if it’s fixed and allow closure of the thread.

FOURTH UPDATE: The problem immediately came back and I don’t know what to do anymore.

1 Like

I don’t know if edits send notifications so I’m gonna comment again just in case, for visibility.

So if I’m understanding your updates, you’re hosting the jquery source? Have you tried (at least for testing purposes) calling the remote source from google or another hosted version? Also, what version of jquery? If it’s not compatible then it will continually spin like you’ve described. For clarity, I don’t know what the compatibility issues are but I have had the version used not work while another did so it’s just something else to try).

No. Dreamhost hosts the whole FTP server. The version of the Jquery is 1.12.4:4.

What ‘hosting the source’ means is that it is stored local to the work you are doing on the same server (doesn’t matter if it’s dreamhost, godaddy or someone else). This is not normally recommended as the version of that code will become outdated before long. However, if you are using version 1.12 then try version 1.10… as I’ve seem compatibility issues cause the problem you’re describing.

And how do I do that? On my theme’s Functions.php? Cuz I already tried and it didn’t work :frowning:

EDIT: Yep, definitely doesn’t work through functions.php. I’m getting a 500 internal server error.