Invoice has wrong date for timezone

Is there a way to have invoices sent with the data correct for the timezone of the buyer? We’ve just done a test invoice from Australia but the date is one day behind (presumably from American timezone).

Hi Peter, just to make sure I am on the right rack are you using the Invoice that has the payment enabled?

1 Like

Hi Amanda. I’m afraid I don’t quite understand the question (not a InfusionSoft expert… yet).

We have configured the system to send an invoice email upon purchase (paid through PayPal). The date on the invoice does not seem to be based on the purchaser’s timzone (which is set to Sydney in their Contact record). In the invoice, both the “Date” and “Due Date” show 14 Feb, but it’s already 15th Feb here. Here is a snippet from the invoice editor:

Since you are using the template change the Date Merge field to|plus__days(1)|short~ that will display the correct date for you. To see more date options check out this other Community Post

1 Like

Thanks, Amanda. That did the trick!

This will only work for the day the invoice is created and sent.
What if the customer calls up a month later asking for a reprint of the invoice.
If you use the “TodayFilter” on the invoice it will always give the date that you actually send it - Not the actual ‘Real and Legal’ date the actual invoice was created.
So, how do we fix this correctly and make sure that the invoices are stamped with the correct local date and not American Eastern Time - Without having to use workarounds that don’t work…??