CURL Request forms failing

For a little bit over a year and a half now, we had a form on a website.
What happened when this form once submitted was grab all the data, create an object with it containing all the correct field names and data needed for the campaign, and then use a CURL request to post the data to infusionsoft while sending an email based on the data collected. Recently, this has stopped sending data to infusionsoft completely. I went around trying to find some fixes, and tried to implement them with no luck. Some examples were adding these to the curl request:

    $headers[] = "User-Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_10_3) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/44.0.2403.89 Safari/537.36";
    curl_setopt($ch, CURLOPT_HTTPHEADER, $headers);
    curl_setopt($ch, CURLOPT_RETURNTRANSFER, true);
    curl_setopt($ch, CURLOPT_FOLLOWLOCATION, true);
    curl_setopt($ch, CURLOPT_COOKIEJAR, ‘name’);

OR even finding out that the url could possibly have changed from to and testing the new url.

No luck with these “fixes”. I then went to the infusionsoft support chat and tried to get some sort of fix, but was ultimately told it was a known issue currently with no estimated time for completion. Also, they told me that somebody here may be able to help out, and now here I am.
Has anybody else run into this issue or something similar, and if so, what was your workaround or what did you ultimately end up doing?
I really don’t want to have to rebuild everything through the API if I dont have to. It just seems like a lot of unnecessary work since everything was working fine before. Thank you in advance.