Campaign merge field errors (links to Wikipedia 404 page)

Customers have emailed us to say the links in one of our campaign emails are broken.

Here’s an example: HTTP 404 - Wikipedia

It should go to our Saboteur Assessment results, but instead goes to Wikipedia’s page on 404 errors.

For each contact, the custom field value is correctly populated with a working link.

Infusionsoft chat has not been able to identify the problem. There is no similar issue in Known Issues.

Has anyone encountered this issue?

Looks like it’s a recurrence of this issue:

### Links with URL’s containing merge fields are resulting in a HTTP 404 Wikipedia page when clicked.

Campaign Builder

Last Updated: 04/02/2019

Issue Number: 1586140

Date Reported:

Monday, April 1st, 2019 11:37am MST We have identified the root cause and implemented a fix for these errors. --------- Monday, April 1st, 2019 10:50am MST When you receive an email from Infusionsoft (broadcast or campaign) with a link that directs to a URL that includes merge field information in it, the HTTP 404 Wikipedia page is appearing instead of the intended destination. This was first identified 3/29/19 at 6:41pm AZ time. Our developers have determined the cause of this issue, and it should be resolved in around 1 hour.

Alternative Solution:
None at this time.


This is a real mess :cry:

I am having the same issue.

Any updates on this?

Yes me too all my tracking links are getting 404 page error

Me too

I am having the same issue. No one answering the phone support and their 24/7 support chat is unavailable.

Unbelievable Keap!

There are a number of reports of this issue returning (they currently show it as resolved). So anyone experiencing this submit a ticket and reference the issue number 1586140 so they can open up investigating it again.

It is 9 Aug 2021 and I am now getting this same issue. The link is correct in my Campaign but when the email is sent and clicked on by end user it goes to Wikipedia 404 Error.

Is this a common issue for others, or just me? Is there a fix I need to do at my end, or is it a global error that needs to be fixed?

Possible work around that worked for us:

We changed the link to a vanity link that redirects to the one with all the params and it worked