Button link working in email broadcast for some people and not others

Yesterday, I sent out an email broadcast that invited our clients to an event. I created a button that says “Register” at the bottom of the page. It links to our webpage where there is a form to register for an upcoming event. The button in the test email works as it should. I changed the subject of the email and nothing else before sending out the broadcast.

I received a message from a client this morning that the link to register did not work for them. I tried it on my computer, and it did not work. It give you a redirect message, “sorry, but we were unable to find the page that you were looking for.” The link does work in the HTML preview in the broadcast report. I talked to other people who I work with (we are all remote). 2 of them said it works for them, 1 of them said it does not work for them.

I contacted Infusionsoft support via chat and phone. I did not get a satisfactory answer. They said that it was either my email server or my ISP, because it worked fine for them when they tested it.

All 4 people in our office have the same email server, so that should rule that issue out. I also tried to open the link from a different location that has Comcast. I have Century Link. No luck at either ISP. I have cleared cache and tried Chrome, Safari, and Firefox. I tried my phone disconnected from wifi. Nothing.

This is very frustrating because the whole point of sending that email was for people to click the “Register” button that maybe doesn’t work. I have no way of knowing whether or not it works for the majority of our clients who received the email.

Also, in the email batch report the “Opens” report does not show that I opened or clicked on the link. I have opened the email many times today. It does not show that my other colleague with a broken button opened or clicked on the link, though I know she opened it.

It does show that my 2 colleagues with the working button opened and clicked on the link.

Any ideas of what could be going on?


Hi, @Cindy_Lamir. I wouldn’t rely on an open rate report to troubleshoot an individual problem…those reports should be regarded as an estimate to give you an idea of how well an email performed - they will record both false positives and negatives.

My guess is that your website or the specific URL you were linking people to was unstable (up and down temporarily) which would explain why it worked for some and not others. The only way to test that theory would be to know what the URL was that housed the “sorry, but we were unable to find the page that you were looking for.” error message - that doesn’t sound like an Infusionsoft error message, but I could be wrong. Are you still able to click the link and go to the error message page? If so, just paste that URL here along with the original link that was in the email.


Thanks for getting back to me. The error is an infusionsoft message. Screenshot is below. The logo is on the right of the page: ttps://xp298.infusionsoft.app/app/linkClick/2336/f3fac7a5711008e1/22066/afe762ad84988b2d?cookieUUID=2e274f30-5470-42cb-af27-84efb64f9169

This is link it should go to:

I have heard back from a few more people 1 it does not work for and 1 it does. All in different states, different ISPs, same email server.


@Cindy_Lamir, I’ll be private messaging you for more details

Did you find anything else about this? I sent the emails to you, and I have not heard anything back. Thanks!

Hi, @Cindy_Lamir. I turned this over to a support manager last Thursday…sorry that I forgot to tell you. They have attempted to contact you via phone and email. If there is a better way to reach you, just reply to my private message and I will forward it on to the team.

Please have them contact [Removed by Admin]

Thank you,


I clicked on the link next to the image and it redirected me to a landing page. I clicked on the IS link above the image and I receive the IS error. Could this have to do with the URL beginning with “ttps://“ instead of “https://“? Just a thought.

Hello, I am having the same problem as described above. Can you please contact me if you found a resolution, or even a work around to determine who needs an updated email? Thanks!

This is what the Infusionsoft tech said about the issue:

"I just wanted to reach and let you know, it seems I have found the issue.

The link that’s connect to button has https, which causes issues. When I first sent it to myself with the s, it gave me the same error. I took the s out and then tried sending it to myself and it worked without any issue."

We did not find any work around for figuring out who couldn’t use the link so we resent it to everyone.

So is your strategy moving forward to never include the s of https, or just not include any of it from now on?

Thanks for the response!

Sorry for the long delay in my response! I have been excluding the s in https in the links, we haven’t had the issue again.