Zapier Error (10)

Hi, I want to REPORT a BIG BUG. I almost got headache from this. However, I deleted some custom fields I never use and then Zapier suddenly stopped working and give me those errors. So I thought I reassign the custom fields 1 by 1 and then it worked again (look screenshot). The Error (10) is happening.

So I can’t delete my custom fields forever? This is kind of … hmm

Only thing I can think of there is that maybe if any of those fields are used in another zap?

Had this issue too. Did you ever find a solution other than adding the custom fields back? I deleted one which I 100% had not used in any zaps. Now I am close to max custom field limit and have a bunch I want to delete but I’m worried it will break all my zaps if i do!

I think it has to do with trying to specifically pull this contact record. I think that if you try to pull a new record you will be fine. Adding back the custom field won’t work because you can never add back a custom field. If you had _customfield and delete it, then add it back, it becomes _customfield1 – differnet database name.

If you trigger this zap again and then go to the Test Trigger and pull in the new contact record, see if it gives you the same error … I’m guessing that it won’t, as that new record never had the old custom fields so Zapier does not know to look for and expect those records, whereas for the old test trigger record, Zapier knows that those fields used to exist so it is now looking for them and throwing the error.