Update Person Notes via REST API

Good day,

I am trying to backfill Person Notes for a bunch of contacts by using Update a Contact API (i.e., PATCH /contacts/{contactId})

It appears to work well for many fields (e.g., job_title), but updating “notes” doesn’t seem to do anything. Here is the simplest JSON body I tried sending to the server:


Thank you.


So if your post is accurate then you will need the outside quotes to be single quotes (or reverse it) in order for it to work.

Thanks for the response, John. The outside quotes are actually not passed to the server; I updated the post. The issue is that the exact same call where notes is substituted with say job_title works as expected, but doesn’t do anything when the field is set to notes.

I don’t know why job_title would work for you but I do know that it’s not supposed to have brackets around it…

“lead_source_id”: 0,
“middle_name”: “string”,
“notes”: “string”,

it is an array element, not an array or object itself.

For clarity, this is the entire body of the request. Every other request I had been sending was with curly brackets around it as per the documentation. I tried without them for the fun of it, and the API returned error Bad Request. The fact that job_title works but notes doesn’t leads me to believe that there is an issue on the API side with handling this particular property.

To be thorough I threw this into Postman…worked first time:

Thank you for your help John. By worked you mean the updated value actually appeared in InfusionSoft? I am getting a positive response from the API as well, it’s just the record in InfusionSoft doesn’t get updated. The Person Notes tab is still blank.

I’m seeing the same, unexpected behavior, @Anton_Loukine. I’ve filed a bug ticket and will let our PM know about it.

Thanks, Mike. How long do these things usually take to resolve? Is there a workaround in the meantime?

Sorry @Anton_Loukine,

I was thinking you meant that it was throwing an error for you and in fact, it did not update the person notes as you’ve indicated. Let’s see what @mike.christianson comes up with.

Turns out the fix is straightforward; I’m working on it as I write this. If all goes well – testing and release schedules are affected by US Thanksgiving – you could see it as early as next week. I’ll let you know when it’s in production.

1 Like

Thank you for your help, guys.

@Anton_Loukine Fixed; thanks for bringing this to our attention. See: API Additions and Changes 2017-12-06.