Safari not displaying JS forms, too many redirects


Recently we started having issues with Infusionsoft forms on Safari browser. In console we can see error:
Failed to load resource: too many HTTP redirects and form does not show up at all. It seems that it’s only Safari issue (11.1.1)

We are using Infusionsoft form within an iframe on a Wordpress (latest) page.

it looks like it’s not only our problem because I found other forms here on this forum that throw exactly the same error: Apply Now - Merchant Solutions LLC

I am having the exact same issue, it was not occurring before. It is happening on IOS as well. Does anyone have any insights on this one?

This made it to the known issues page today. If you haven’t already, click the button to report it so that you know when it’s fixed.


1 Like

I’m having the same issues on Safari - Infusionsoft form not showing on my iphone. I’m not seeing an error message though.

I clicked the “Report this issues for your app” button as described above.

Thank you,

Great, have been struggling with this problem too. Have reported the issue.

This has been fixed

We noticed today that the problem reappeared. Are you guys aware of this and will be able to fix it soon?

We are running into this issue again, this time with Chrome 78, beta/79 and canary/80.

Firefox 70, Edge (Win10) and Edge Chromium 80 all appear to be working fine.

Looking at the logs, it appears that Chrome doesn’t honor set-cookie directives with 302 redirects possibly?

1 Like

We are running into this on Chrome. I’ve tried on our website, and also one linked in this thread and get the same issue.

I was concerned it was just our site, but it looks like Chrome is possibly having a problem with Infusionsoft forms overall.

Same problem on Chrome Version 84.0.4147.89 (Official Build) (64-bit)