O365 Emails stop syncing every few days

We seem to have an issue where Emails stop syncing to Keap every few days. We have to disconnect and reconnect the accounts every few days. The synced accounts still say active but they show last synced X number of days ago. We have been through support about 25 times on this and they say they will look into it and get back to us, account manager directs me to support when I reach out to him. Has anyone experienced this and can provide some tips or a resolution? (We have removed and readded the accounts multiple times). I am an admin in O365 so if its something to look into on that end I am happy to explore.

Yes this is really causing us problems - It is appearing totally unreliaable I keep reconnecting but it is not stable enought :frowning:

Yes, we are having the same problem and we’re not getting the necessary help. Emails sent from 365 to a Client, aren’t being recorded in Keap. It appears I can’t forward any history into the system either. No warning that the sync isn’t working so going forwards, I don’t know what we should do. This should be a core function of a CRM system, to keep everything in one place.
They recommend disconnecting to reconnect, the test works, but then nothing more. Email deliverability of a nurture campaign today, where two leads have tried to make contact again (they’re clearly not receiving the emails) has prompted contact direct via 365. Still no sync with Keap.
I have asked for any pointers on SPF/DMARC/DKIM so we can check those and the chat couldn’t help. What should we do?

Hi so to check your SPF go to SPF Surveyor - dmarcian and put your domain name in there. You want to see include:infusionmail.com as part of the response.

DKIM, if you got to Settings > Domains you should see you domain listed with a green tick.

DMARC is a bit more tricky, and beyond what I can support with here to be honest.

However none of these should be causing you sync issues with outlook from what I understand. These are all to do with delivering your emails in the first place, not receiving them back and syncing.

Sync isn’t historic in nature, only ‘live’. Hope that helps a bit.

All the best

Andy thank you. I think there might be something in the SPF point and will take a look at that.