Infusionsoft message: Access denied

I have successfully connected Infusionsoft.
“Successfully Connected to Infusionsoft - September 06, 2022 12:19:05 PM”
" Authorized Connection to Infusionsoft on September 06, 2022 12:19:05 PM"

But I get an “Access Denied” message under “Infusionsoft Response” when I check the entries in Infusionsoft Logs.

Good afternoon,

It appears that you are using a third-party toolkit or application; there is no clear indication of what your problem may be from the messages you posted. I would recommend contacting the maintainers of your toolkit for further analysis.

Hi, please attached image. It’s an Infusionsoft integration plugin for Gravity FOrms.

That is a really old plug-in that we have replaced for all our customers (and age could be the sole reason you can’t get it connected). If not using something like Zapier or Make, the plug-in from CRM Perks works really well and gives you lots of functionality. You do need to upgrade to a paid version to be able to add tags.

Hope that helps.


Hi Jeff,
Thanks for responding. That plugin is from CRMPerks, see attached image.

I will check Zapier or Make. Thanks for suggesting.

Sorry … been a while since I’ve worked with the backend of the plugins. CRM Perks typically has pretty good tech support - they helped me with a few items when we first got started with them - so they may be able to assist.

Hi Jeff,

We tried with Zapier but it still doesn’t work.

in the top of that Zapier step … when you connected Keap to the system, did that come back and say that your connection was successful? I’ve never seen where the connection was successful, but then you get this type of error.


Hi Jeff,
Yes, it showed the integration was successful.

Is the account you are connecting with an admin account? If not, it may be a permissions settings issue.

Hi Jeff,
How do I know it’s an admin account? Right now I can’t see anything in the profile that implies that.

You would see this at the top of the permissions:

Also, inside the user account info, they would be part of the ‘admin’ group.


Thanks, Jeff. That helps.