Getting 403 Forbidden Error while using API

Hello all!

I’m trying to fix an error with an API connection that’s returning a 403 error. I’ve talked to the plugin developer, the host and Infusionsoft support.

Specifically using Memberium as a membership software and they require a plugin called i2SDK. Besides that, has anyone experienced a 403 Forbidden error when using the API and do you know the cause? I have been looking at this way too long and thought I’d reach out to see if anyone else has seen this happen.

Thank you so much!

Hi Heath!

I’ve run into those forbidden errors mostly when I’ve been trying to authenticate through OAuth. In every case it’s related to my application not being approved yet in the Infusionsoft developer account. If the status of the app is “waiting”, then you won’t be able to use that client_id and client_secret to authenticate with the API.

Here’s a screenshot of what it looks like:


On another note it can take a frustrating amount of time for a new app to get reviewed and approved, so it’s often easier to just create a new login to the developer portal and create a new app with it.

If you’re running into that issue somewhere else in the process, like you’ve got the right tokens and stuff but you’re having that returned on regular API calls, include that detail and I’ll see if I’ve got any other insight.

(Edit: the status that you’re looking for to know that you’re app has been approved is “active”)

Thanks Damon,

I appreciate your help!

I made server updates and plugin/wordpress updates and something worked. It may have even been an update to either Infusionsoft or the host that fixed it, but it’s working now!

1 Like