You need to have at least one Infusionsoft Account linked to your user in order to grant access

When I registerd myself here and hit the authorize button I get “You need to have at least one Infusionsoft Account linked to your user in order to grant access.” error when login through a newly created account here at this platform.please find the attachement below.need help!

top of the list on the left there is a button to authorize first named ‘try the api’. Authorized through that first and then you’ll be able to make calls:

@Radhesham_Khatri That error is saying that you need an Infusionsoft application that you are linked to in order to authorize the usage of the API.

then tell us how to solve this error @bradb

You need to have an Infusionsoft Application. We do have a free trial you can sign up for, if you are not the consumer.

1 Like

Yes, this worked for me. Thanks

1 Like

But not worked for me. On the API docs “Try API” button, when I enter my client_id+secret - redirects on page with the same error.
On this link: - when I enter my credentials, it open the page with infinite spinner, and I see this error in console:[object+Object]=
403: {“error”:{“status”:“PERMISSION_DENIED”,“message”:“Input userId must match current user”,“code”:7},“retryable”:false}
I don’t know why, I simply enter my credentials, nothing else.
It looks like your application cannot work with your api too. It seems that api is very raw and contains errors.
Please tell me, what needs to be done, otherwise I will have to recommend the customer to look for another similar API, because today I spent many hours and could not get access to the API and try it out.
My client_id is: 4sdzm6xbkucdw8ace4cr7zar

If you login to mashery, is your app/credentials approved or pending? Note, you can have an id/secret pair and still have a pending status.

I have verified your client_id is valid and enabled. I looked up you Keap account on our side using the email you used for registering your developer account. I am showing you do not have a Keap/Infusionsoft app assigned to your account. Did you register for a free trial?

1 Like

I’m register with a my google mail, and about free trial… It’s a second link? It shows me infinite loading wheel. I can’t perform any action on it (using chrome or firefox)

This gives you an infinite spinner?

Here is a screenshot with infinite death wheel and error requests.
Such errors appear on console when I just logged in, or click on any left menu item.

I also try to enter this application with Firefox - nothing works too

I’ve seen that with some browser plugins. Have you tried without any plugins running and I don’t think firefox is the most functional browser for IS. Have you also tried Chrome (which is fully supported)?

Actually, this is screenshot from chrome.

Was just going by comments but that doesn’t account for plugins or cache. Have you tried those options too?