Emails changed in Infusionsoft revert back to original within 30 minutes


We are running into an issue where we will go into a contact record and change the email address, but within 30 minutes the email will revert back to the original email address. This started happening about a month and a half ago. We’ve not changed any of our procedures to cause this and all users in our account see this behavior so it’s not user dependent. Thanks for any ideas.

Sorry, @Mike_Inglis never heard of that. Are you updating contact records with the API or are using any 3rd party plugins that make changes to contact records? Are you updating contact records manually using another systems contact id as the primary key?

Hi @martinc, we are updating the records right through the Infusionsoft app. I’ve done some experimentation and it only seems to be the email address that reverts. Other fields remain changed.

I’ve tried creating a new contact with the correct email address and then merging contacts but the same thing happens. The email initially is updated correctly and then 30+ minutes later it magically reverts back to the original.

This is incredibly frustrating as when I’ve worked with IS support, they say “Well, it looks like it changed correctly so it should all be good.” And of course when I’m on the chat with them, the email stays changed. But then when I come back later to check, the email has reverted to the original again.

I asked to have a case number but I don’t actually know who to send an email to to try and debug this via email.

I’m sorry, Mike. I don’t have any other ideas for you. I would replicate it again and take 2 screenshots showing the email address along with the last updated timestamp before and after the email reverts back. If the last updated timestamp remains the same and the email changes, I guess that would be proof that something isn’t right. It sucks that I have to put the burden of proof in your hands, but I’m out of ideas and it’s probably the best way to get it escalated with Support.