Anyone here use WordPress and Zapier integration

I’m half out of my mind…

We transitioned our initial website designer to another.

Since then, I cannot post WordPress Blogs using Zapier.

I’m able to successfully add (connect) to InfusionSoft in Zapier, so no issues there.

But when I run a test - I get an Unauthorized 401 Error - I’ve looked everywhere, and I do mean everywhere for guidance to get this fixed. So that tells me Zapier doesn’t have the permission to retrieve the post.

Zapier says to contact our website dude - The website dude says to contact Zapier…

The only consistency I’ve seen is related to “reCaptcha” getting in the way (yet we do not use that anywhere).

I use Zapier for many things, I would hate to move over to another system but even if I did, I’m sure I’d have the same problem.

Any help would be SOOOOOOO appreciated!

1 Like

Hi Cindy, so what data are you trying to get from WordPress to Zapier?


We schedule our Blog Post to run each Sunday morning in WordPress - I was sending it to Facebook, Instagram and Twitter via Zapier. Now I’m getting an error when Zapier tries to pull the Post - I’m NOT having a connectivity issue, it’s when the Zap is attempting to pull the post…

(And thank you for responding)

You’ve given me a little hope over here…

Does any data get to Zapier, or does it fail to fire in the first place?


In Zapier - You have to manually connect WP to Zapier using my login credentials for WordPress (I’m an Admin).

When I get to the area where Zapier asks me “What do you want to Pull”

I’m able to connect just fine.

When Zapier looks for the data - Nothing is appearing (I have connected/reconnected 100 times, even used different login)

Here are the exact steps I am taking:

Hmmmm interesting.

So ASSUMING you have the right account connected and you’ve tried whats suggested here on Zapiers help page, then unfortunately it is a case of getting your web techie and zapier to have a conversation. This isn’t easy to do I agree.

I’ll keep my brain ticking on this in case I remember the same issue for someone else.


Yes @Andy_Wroe - The accounts connect just fine - It’s when Zapier tries to pull the published post from WordPress is where it returns the error.

I already tried getting our WebHost to take a look and he too has no idea…

I’m going to have to throw in the towel and find another system - But I’ve a feeling I’m going to have the same problem if it’s a security issue…

Feeling pretty defeated…


Sorry to hear that, did you check the jetPack thing (technical word) thats in the help file?


I’m told we do not use Jetpack …This too, so very frustrating…

I know enough about WP to do simple things - Zapier, I’m a bit more advanced until they start telling me to get technical - And of course, cannot help…

I’m moving to the mountains…

Or make the mountain move to you!

Wish i could help more, sorry Cindy


This issue is making me search far and wide and along the road - I’m learning more…THAT, is a good thing.

I’ll have this fixed by the end of the day and will be so happy to come back and gloat!

{holding myself accountable}


Still NOT gloating…

Hoping today is the day!