Unexpected API Results


I am using both ARC and Postman to test the REST API, but I keep getting the same error message. I have my access token, which I know works because I don’t get the “Developer Inactive” message, but I’m not sure what else I’m missing.

The message I keep getting is “We’re sorry but this site doesn’t work properly without JavaScript enabled. Please enable it to continue.”

In my header, I have:
authorization = [access token]
accept = application/json, /
hsot = api.infusionsoft.com

I’ve also tried using the access token within the URL (?access_token=[access_token])

They all return the same response.

Any idea what is going on?

I’ve heard of errors like that happening when using the browser extension version of those applications rather than the standalone app. I would try downloading the standalone version of Postman and give it another shot.

This is definitely something that is common with the browser version of postman. I use the local downloaded version and have never had this happen so give that a try :wink:

I am using the standalone version that was downloaded and installed - not the browser extension.

I’m wondering if it has something to do with my account or my company’s Keap account.

Theoretically, I should be able to perform the same request in my browser by providing the access_key parameter in the URL, right? So using https://api.infusionsoft.com/crm/rest/v1/hooks/event_keys?access_token=[access_token], I should see a JSON output, right? However, I get the same results as what I get from Postman.

See attached screenshot:

Update: the results are the same with the Infusionsoft PHP SDK library.