Spurious 'InvalidConfig' error in Legacy API

Getting a lot of Error 1 ‘InvalidConfig’ errors from the legacy API - indicating bad API Key, but the error is random and occurs to lots of different apps.

Anyone else seeing this?

InvalidConfig can be thrown for many situations not just a bad legacy key. There should be a description along with the InvalidConfig. What descriptions are you seeing?


The only description I’ve ever seen associated with this error is this: Invalid Configuration: for help setting up your API, please contact Support (1-866-800-0004 ext. 2)


Is that from the SDK or the raw xmlrpc response?

We only emit that particular error message in a couple of cases, all of which involve the key being passed either being null or malformed.

I assume you using the Legacy API Key, have you tried implementing OAuth and seeing if it prevents the intermittent issue? We will eventually be deprecating the Legacy Keys anyhow, so it would be good future-proofing to do.

I see the same description in both places.

I provided the full raw xmlrpc data in this ticket history.



This issue is that the error occurs intermittently, then disappears, without any changes in API key sent on our end.

I provided the full raw xmlrpc in this ticket history. So I believe you or another knowledgeable developer in Infusionsoft can use that to confirm a valid key was sent?


I’m sorry, this section of the community is mostly monitored by the API development team, and we don’t have direct access to the support ticketing system. If you send me the ticket number directly I can walk over to speak with our support reps to get the content.

Also - I am transitioning to OAuth - that is well underway but it will be some time before it is fully complete.
As you know, OAuth has it’s own set of issues - legacy is overall more reliable.


It is 00907323

I spoke with our support reps and the ticket it open and with Daneil Greenlee at the moment; he should be reaching out to you directly to get it resolved. From looking at the notes with my support contact it appears that the actual token getting sent is an encrypted string, not the actual API key.

Was there any resolution to this? I’ve got a client with an urgent issue and we’re seeing this error. First time every on a similar setup we’ve used a ton in the past.

Tyler - I was never informed of any resolution and the problem subsided.
I still see this error a couple of times per week and retries seem to get around it.
If you are seeing a persistent error, I recommend you ask your client to use a different passphrase and generate a new key, if you haven’t already tried that.