Https Web hook URL?

I’ve setup a REST Web hook for order.add. It works great when create a hook to a straight “http” url but when I create a web hook with “https” it won’t verify. The verification call just returns “Unverified”. Setting up the same webhook without the “https://” and just “http://” it works fine. That hits the same endpoint on my server so I know it’s not a coding issue. Is there a limitation with https web hook urls? If so this is a problem as legally and for security purposes I have to require SSL for all communications with my server. My Infusionsoft integration was the last piece of this and I just spent 3 days converting from to web hooks from the “Success Purchase action” that has worked for years but found that didn’t support https either. Please tell me I’m doing something wrong or if there is some way around this limitation. Seems crazy that its 2019 and a company like Keap/Infusionsoft cant make a simple https request! Please help! Thanks!

Could you try out the delayedVerify request? I was able to confirm a hook via Postman using that method. Curious if you’ll have similar results.

Thanks for help but I added some logging to my hookURL so that I could get the X-Hook-Secret to use on the delayedVerify request but it seems like when the url is https Infusionsoft is never making the request to my server. I see in my logs the X-Hook-Secret when non-https but not any logs for https. Even checked the apache access logs and it seems the https message is never getting sent from infusionsoft to verify. I used a tool (doHttp) similar to your postman with an https request and saw that in the logs so again it seems as the Infusionsoft is not making the request. Is there another way that I’m missing to get the X-Hook-Secret so I can try the delayed verification?

Thanks again!

Any other ideas or ways to get the X-Hook-Secret since it seems the validation service is not even making the https call to my server? Thanks for any help you can provide.

tim did you ever figure this out?

Unfortunetly no. Still not working but I also haven’t had much of chance to look into it. I do have a major integration overhaul project coming soon which I will REALLY need to this work. Any thoughts or are you having a similar issue?

yeah i’m doing all of the same stuff and am as far as the token, but i get a 596/fail when posting to create hook infusionsoft url. i’ll post a detailed video/instructions once i figure it out. i think many will benefit.

i’ll also let you know as soon as i do.

Awesome thanks…feel free to bounce any ideas you have to. I’ll be getting back to this very soon.

tim, i figured out the verification and am going to create a detailed video soon and post to the community. just wanted to let you know that i think i have the help you were asking for. are you building in .net by chance?

That’s awesome. Can’t wait to see what you had to do. I am doing this with a Rails instance not .Net but hopefully i can take what you found and apply to my instance.

Hey Steve,
Did you ever create that video you mentioned. Just getting started on this and would love to see how you got it to work. Thanks for an info you can provide and Happy Holidays!

i created the oauth one, but not the hook one yet. what stack are you using for your implementation?

i think the text is way too small, so i’ll probably change some video setting to blow up the size.

You rock thanks! I’m using this via Rails with Apache

If the verify is failing with https then it is most likely due to to our https client not liking your SSL cert. If you give me the url you are using to verify I can take a quick look.

Awesome - thanks Brad. Current url I am using for testing is

Can you also send me the app name you are trying to register a hook for. Also I know that its has been awhile since you last attempted a hook registration so could you make another request to make sure it is in our most recent logs?

Ok app name is “OnSpot Account Management Dev” and I just tried again to verify order.add. Thanks for the help!