Help identifying cause of GetContactTagIds API call fail

Hello. A little more than a month ago, our InfusionSoft integration broke in that the contacts are still created (with the information and custom fields filled in) BUT the notes are no longer being stored and the tags are not being applied automatically.

We are using an InfusionSoft wrapper to connect our website to InfusionSoft.

The API call that is failing is GetContactTagIds, returning the error message below

response contains implicit string value where dateTime expected [response : array mapped to type ContactGroupAssign : element 0 : struct mapped to type ContactGroupAssign : member ContactBirthday mapped to type DateTime]

Any insight as to what is causing this error and how to fix it would be much appreciated. Thanks!

I’m assuming that you are using the C# SDK from the text of that error, but is ContactBirthday a custom field? From the Contact definition in at library, the Birthday property of Contacts appears to be named simply “Birthday”.

Thanks for your reply, Tom. Yes: using C#. As far as the data coming through the API integration, birthday has not been collected. The integration worked fine for at least a month.

Two changes were made around the time the tagging stopped working:
(1) a separate campaign was created in InfusionSoft using the webform submitted goal–and that form included birthday as a required field and was published on the site through an iFrame.
(2) we created some new document types in our CMS, but these are do not connect to InfusionSoft

Have been unable so far to pinpoint if or how these may have caused the problem; and, more importantly, how to fix the issue.

Appreciate the help!

There haven’t been any changes to the C# SDK in a while, and the Contact endpoints haven’t had any changes recently in XML-RPC API (which that library uses) recently, so I’d point to something in the campaign. Could you create a ticket and reference this thread so that we can possibly assist more directly? Support will be able to look at the data in your system to try and diagnose the issue.

That makes sense. I do have a case open currently, but no response since I replied to initial questions on the 4th. I will add a note there referencing this thread. And if still no answer after another day or two, then I will open a new ticket.