General error on Retrieving a single Campaign

I’m testing the Retrieve a Campaign endpoint and I keep getting a “General error” with the following response headers:

  "x-plan-qps-allotted": "25",
  "x-plan-quota-allotted": "125000",
  "pragma": "no-cache",
  "x-plan-quota-reset": "Wednesday, July 12, 2017 12:00:00 AM GMT",
  "x-mashery-message-id": "ac3b508c-a3d3-4a53-a8ef-162d195aeecf",
  "content-language": "en-US",
  "x-plan-qps-current": "1",
  "cache-control": "no-cache, no-store, no-store",
  "x-plan-quota-current": "18",
  "content-type": "application/json;charset=UTF-8",
  "x-mashery-responder": "",
  "expires": "Tue, 11 Jul 2017 12:39:52 GMT"

I’m sure that the campaignId is correct since I copied it from the list that I got from the List Campaigns endpoint. What am I doing wrong?

Sorry to hear you are having trouble using the interactive REST docs. I seem to be getting the same “general error”. I am checking into this and will update this thread with more information once I have an idea of what is happening.

It looks like we have a fix for this issue. We have an updated version of the docs that will be coming out in the near future. I will try to get an exact release date and update this thread.

Do you have a release date for the fix?

Hey @Von_Villafuerte, sorry for the delay, the release date for the update to the REST API docs is planned for tomorrow 7/18/2017.

This is great news! Thanks for the update.

Hey @Von_Villafuerte I wanted to let you know that the REST API docs have been updated.

1 Like


In testing this out, if one optional property or the other is included, all runs fine. If, however, both are included as in ‘sequences, goals’ then the following is returned:

“message”: “The following optional-properties are unrecognized: goals”

If I reverse the order than the second one is always what is mentioned in the message. I think more work still needs to be done on this one.

Try removing the space you have in between “sequence,” and “goals” so that the parameter value is sequences,goals.

Thanks! That works. It’s odd behavior though :stuck_out_tongue_winking_eye: