Did anyone else lose access to the API today?

Our system can’t access the infusionsoft API starting today. Anyone else have the issue?

Hi @Noah_Nehlich, if you are still experiencing issues would you be able to tell me the error you’re receiving as well as whether you’re using OAuth or Legacy API keys?

Infusionsoft seems to have belatedly turned off TLSv1 this week (they said previously that this would happen back in April), now requiring all API connections to be secured via TLSv1.2 . If your servers are not updated to work with TLSv1.2, then this could be your problem.

We are getting the same issue, however our server is running on TLSv1.2. Would it be an IP blocking issue from Infusionsoft?

No, we don’t block individual IPs on our end, as all traffic is proxied through Mashery.

@TomScott, you mean that all API requests (OAuth and Legacy usage) are now being proxied through Mashery?

We have the same issue. Using legacy API keys.

Could not create SSL/TLS secure channel.

We’re using TLSv 1.2


I am experiencing the same issue with 2 plugins on 2 different websites on the same server. I’ve contacted the server provider and they’ve told me “Everything on the server level is up to date and has the ability to use tlsv1.2. You should reach out to infusionsoft to inform them of the issue.”

What needs to be updated in the API?

We’ve researched this a bit more and worked out our problem.

.net code, using .net 4.6, but we were referencing the Event Day Infusionsoft library through NuGet, which was compiled for .net 4.0 and not using TLS 1.2 . The latest source on github for Event Day’s library has been updated to 4.5, so we compiled that and are referencing that now instead of the NuGet version.

All working.

Only OAuth, sorry.

We are experiencing issue since yesterday around 6 am. We updated to TLS 1.2 and changed our script ( ServicePointManager.SecurityProtocol = SecurityProtocolType.Tls12) and nothing works. We are getting an error message like this:

we’ll try @Craig_Foley’s approach and update our post

Had the same issue. Was using XML-RPC.NET from Cook Computing. Managed to find source code and created a 4.5 build. Had to make a couple mods due to .NET 4 security. Then added the lines below to my app and now we are back in business:

        ServicePointManager.SecurityProtocol = SecurityProtocolType.Tls12;
        ServicePointManager.Expect100Continue = false;
1 Like

Is it possible for you to share your 4.5 build of Cook Computing’s XML-RPC.Net? I’m running into the same problem that you have solved.

Hi Kathleen,

If you download the source c# project from GitHub (for the EventDay Infusionsoft code) and build it, then you should be fine.

GitHub - EventDay/Infusionsoft.net: A C# Wrapper around the Infusionsoft.com API (You can download a full zip of the library from that page, which has the fix.)


As it turns out, I didn’t need to do that. I only needed to add the

System.Net.ServicePointManager.SecurityProtocol = System.Net.SecurityProtocolType.Tls12;

line before the

iFace proxy = XmlRpcProxyGen.Create();

calls, and it now works, with the original XML-RPC.Net dll.

Kathleen Wilber