Create/Update Contact always gives me Response Code 0 - no response from server

I am trying to test a REST api call to create/update a contact and no matter what json body I provide, I keep getting response code 0 - no response from server. I thought maybe it was my browser extensions so I tried it in an incognito window and it still didn’t work. Then I tried to use the ‘Try this API’ option (link below) for returning a list of contacts… That worked flawlessly. I even used the json template I got from submitting a support ticket a little while back. No shot.


I am trying to add a contact with only a few fields but I am starting to suspect that it is just entirely broken, otherwise I would have gotten a more helpful error.

If it helps, I am trying to add a contact with contact type, given name, lead source, EmailAndName duplicate checking (though email will be blank along with family name, along with some custom fields. I would also like to add a tag or two if possible.

Later on, I will be adding more conventional contacts with both family and given name but likely still no emai. I will use the Name duplicate option for those.

I am hoping someone will be able to create a short video showing it working on their end along with an example minimalist json payload (containing only the fields I will be using). Otherwise, if someone knows a way to resolve the no response from server error, that would be amazing!

Here are a couple of the PUT bodies I was able to successfully run for that endpoint. Used the fields you mentioned. One with a blank email address, and one without. The third screen shot is what should be expected if you don’t provide at least an empty email, or a phone number.

With an email address:

With an empty email address:

Missing email + phone:

Hope these helps you get this solved!

P.S. - If you are sending a blank email address, the opt_in_reason is not required. I accidentally left it in place in the 2nd screen shot in this post.

1 Like

You are a life saver. Something I was omitting must have been triggering error code 0. Thank you, you have saved my hair… since I would have pulled it out!