500 Internal Server Error when updating contact using REST

Hi there,

I’m trying to make a PATCH request to update a contact and I get {“message”:“General error”} with http response-code 500. See this (removed as it contained an access token).


Could you please let me know what is the wrong here?
Many thanks.

Hi guys, I found another way to update the contact, using PUT instead of PATCH and it works. Hope this will help.


Hi @Dev3_SIMB1, this appears to have been caused by a recent code change on our end and we are looking into a fix. Thanks for bringing it to our attention!

Hi @Nicholas_Trecina Is there any update on this issue ?
I had the same problem and do you have any estimation of the patch release date ?

Hi @Nicholas_Trecina, can you please provide an update on this?

Hi @Nicholas_Trecina, can you update us on when this issue will be solved?

My client is losing leads because of this bug.


@Nicholas_Trecina, can you please let us know what time estimate to expect for the problem to be solved? We are a lot of people waiting, and our businesses are put on a hold because of this.

The fix will be deployed to all customers over the course of today and tomorrow and by Wednesday it will deployed to everyone.

Hi @Nicholas_Trecina

To prevent this kind of incident, do you have any automated continuous integration testing system for each API endpoints before launching the system ? For example like Jenkins or Bamboo to perform CI unit testing and functional testing ?

If you don’t, I’m happy to assist and write something like that to test your API system prior your production launch. :grinning:

Hi @Nicholas_Trecina. Can you tell us from which date you did this code change?

The bug was introduced into production between February 20th and 21st, depending on what release group your app is part of.

Hi @Nicholas_Trecina. What’s the status, -has it been fixed yet?

Yes the fix has been deployed to all customers.

@Nicholas_Trecina. thank you.