[[ contact.contact_type ]] always returns undefined in the dynamic content

[[ contact.contact_type ]] always returns undefined in the dynamic content.
Is it just me or everyone else?

It is listed in the dropdown, I also tried with modifiers like
[[ contact.contact_type | downcase ]]

I also tried
[[ contact.person_type | downcase ]]

All of them return undefined

1 Like

So how do I submit a bug report?
I don’t see chat online. Is there a place to submit bugs?

If you mean the “Person Type” field highlighted with a red box in the image below, then the correct call is [[ contact.type ]].

There is a bug in the Dynamic Content creator, however. When you use the drop down to select the contact’s “Contact Type” it gives [[ contact.contact_type ]], which always returns undefined, presumably because there is no such field name.

1 Like

Thanks, can I ask how you found the correct call yourself?

The old-fashioned way :wink: … trial and error. I looked at the different syntax schemes applied to different fields in the Dynamic Content generator and tried each with the contact type field. [[ contact.type ]] worked with the Dynamic Content previewer, so I assume will work in other places.