Can't edit form in campaign builder

Everytime i try to edit a form in campaign builder, it goes to the form page but then immediately redirects back to my list of campaigns and displays an error that says “You have opened this Campaign in another tab or window. A Campaign can only be opened in one place at a time.” I don’t have any other tabs or windows open and i’ve tried clearing my cache and cookies. I tried opening it in firefox instead of chrome and it didn’t redirect me to the error, but it says i can’t edit it in firefox and to use chrome.

Anyone else having this issue or know a solution?

This has been a known issue that they have been working on for a number of days now. To follow their progress, visit

they seem to have taken the issue off the known issues page, but it’s still doing it for me, i’ve been using edge in the meantime, but edge is annoying.

If the problem still exists, I recommend that you contact Support or raise a Support Ticket via your account.

As for Edge, they are adopting the Chromium engine in a future release, so it will be more like Chrome in the future.