Apply tags to contact Error - REST

I’m testing the REST API Apply tags to contact endpoint here:!/Contact/applyTagsToContactIdUsingPOST

I include a contact ID, and then a single tag in the tagIds box. every time I click Try I get the following message: “message”: “Input could not be converted to a valid request”

I’m not really sure what I’m doing wrong. There are only two criteria - contactId and tagIds. I’m not sure why I’m getting the error. I’ve tried with a single tagId and with 2 tagIds (separated by a comma). Both gave me the same error message mentioned above. Any ideas?

@Joe_Chaiet, the tagIds property should be an array of integers, formatted like [1,2,3].

@TomScott I understand that, but the REST API endpoint test is broken. I’ve tried including the tagIds as a single integer (7270), multiple comma separated integers (7270, 7382) and as an array of integers ( [7270,7382] ). All instances have resulted in the same error message that I posted above.

Hi @Joe_Chaiet, if you click on the “Body Sample” JSON it will copy over to the tagIds text area. From there insert your tag id(s) and click send. Here’s what it looks like for me.

1 Like

@Nicholas_Trecina Thanks. that worked. It wasn’t really that clear that the actual JSON is what goes in the input box should match the actual body sample. I figured the tagIds text box would take care of that.
Thanks again.