[NoFieldFound]No field found: Lead._CustomFieldName

Hey there,

I’m using the xml-rpc api to fetch opportunities including some custom fields. My customer that my company’s software integrates with has confirmed that the custom fields do still exist on their end.

Here’s a gist that shows the requests I’m making.

The first request returns the custom fields for their opportunity module. Its response includes four custom fields.

The second request includes those four custom fields (including the underscores, which most NoFieldFound issues have been missing on this forum) and returns an error of NoFieldFound.

I’ve also researched through all of the following forum posts:

…in addition to this somewhat relevant forum post:

Thanks for reading, hoping to get this figured out as I can not see an issue in my requests.

P.S. I’ve tried throwing some random stuff at it like appending 0, 1, 2, 3, etc at the end of the custom field name in case it had been deleted & recreated. I’ve tried using the field id instead of field name. I’ve tried appending ._fieldId. Just for some additional context of what I’ve tested already ^. Thanks!

Hey there,

This turned out to be an odd one. The customer I was supporting had actually disabled their opportunity module.

Quite curious that I could still get records returned even though the module was disabled and that the error message was describing a missing field instead of a disabled module.

Just leaving this here in case anyone else sees this :+1: